Auto Embed Videos Supported Sites

Kevin

Code Monkey
Staff member
Joined
Mar 20, 2004
Location
Pennsylvania
One of the many features about our current forum software we love is that it makes it really easy to embed videos in posts.

For example, if you've been following the "What Are You Listening To?" thread you'll see an ample number of YouTube videos. When you are ready just copy & paste the YouTube URL into your post like this sample below.

I have no idea why but it's a Neil Diamond Monday for me today.
https://www.youtube.com/watch?v=nhGMmmd9Ixs​

The result of the above post will end up automatically embedding the YouTube video in your post. Click here to see how it looks. Yep, it's that easy! :D

On days where you don't see me posting much one of the reasons is likely that I'm working on tweaking something with the site. One of the things is always working on expanding the list of sites that support automatic embedding of videos. ;)

This is the current list of what sites automatically support embedding videos or, when applicable, pictures or other content.

If you have suggestions for new sites you would like to embed content from please let us know! Some sites do not permit their videos to be embedded elsewhere so while we may not be able to support all sites we will do our best to get all suggestions working.
 
Joined
Feb 14, 2017
Embedded video keeps mobile users away from the thread. It happens on all forums, no big deal.
Here's what I get-


So I just stay out of those threads. If the majority of a forums' threads are filled with embedded video...there's no point in posting. I literally can't post. :meh:
 
Joined
Feb 14, 2017
iPhone 6 Plus

(It's not a big problem at all. I work about 50 hours a week and hop on the forum at work, on my phone)
 
Last edited:

Tom

An Old Friend
Joined
Dec 6, 2004
Location
Gulf Coast
Yes, I realized that from what you wrote so adjusted my posting on your threads so you can enjoy the videos.
You can play the videos from the links, right?
 

Tom

An Old Friend
Joined
Dec 6, 2004
Location
Gulf Coast
General FYI

To remove embed formating of a video there are a few ways it can be done with BBCode.

At the far right of the posting editor there is a button that looks like a T with an x - that removes formatting.
It may also remove the formatting of the link as well.

To make a word become a link you just need to assign the url to that word.
The auto embed doesn't see the bb code string as a video so it treats the word like a link instead.

First write the word(s)
Aynsley Lister - Need Her So Bad
Then highlight the words and use BBCodeXtra to "make URL from selection".

Or you can write out the following code, substituting your video address and words
url=video address]word[/url
[ at the beginning and ] at the end causes markup
 
Last edited:
Joined
Feb 14, 2017
Yes, I realized that from what you wrote so adjusted my posting on your threads so you can enjoy the videos.
You can play the videos from the links, right?
Yes I can! Thank you

Tom- any idea how you "highlight" words on an iPhone?

Forget it! I got it!
Waterboys
 
Last edited:

Tom

An Old Friend
Joined
Dec 6, 2004
Location
Gulf Coast
Forget it! I got it!
Waterboys
Never heard of The Waterboys
Cool. Not too bad, now I gotta go find more to see if I will want to add them to my collection.

I didn't find a #Topic on youtube but I did find an extensive playlist of their songs.
The Waterboys Playlist
Noticing a significant number of songs over 5 minutes in length which is a good indication of instrumental solos.
I like instumental solos.
Plus, I get a Celtic feeling, will need to research the band.

wiki said:
The Waterboys are an Irish/Scottish folk rock band formed in Edinburgh in 1983 by Scottish musician Mike Scott. The band's membership, past and present, has been composed mainly of musicians from Scotland and Ireland with Edinburgh, Dublin, Spiddal, New York and Findhorn, serving as homes for the group. Mike Scott has remained as the only constant member throughout the band's career. They have explored a number of different styles, but their music is mainly a mix of Celtic folk music with rock and roll. They dissolved in 1993 when Scott departed to pursue a solo career. They reformed in 2000, and continue to release albums and tour worldwide. Scott emphasises a continuity between The Waterboys and his solo work, saying that "To me there's no difference between Mike Scott and the Waterboys; they both mean the same thing. They mean myself and whoever are my current travelling musical companions."
1983 The Waterboys
1984 A Pagan Place
1985 This Is the Sea
1988 Fisherman's Blues
1990 Room to Roam
1993 Dream Harder
1995 Bring 'em All In (as Mike Scott)
1997 Still Burning (as Mike Scott)
2000 A Rock in the Weary Land
2003 Universal Hall
2007 Book of Lightning
2011 An Appointment with Mr Yeats
2015 Modern Blues
2017 Out of All This Blue

Thanx
 

Kevin

Code Monkey
Staff member
Joined
Mar 20, 2004
Location
Pennsylvania
Well, you guys/gals got me mentally distracted working on this one! :LOL: It's a good thing though because I like problem solving as a diversion from other stuff and my 'day job' corporate style of programming.

Currently YouTube videos are embedded directly into the page and loads inline as part of the loading the page. If the page has 20 videos on it then 20 videos need to be loaded before the page loads.

The good news is that over on a test install I've got a YouTube "Lazy Load" change working. What a Lazy Load does is to let the page load first, so that it responds to the browser request and comes up pretty fast, and then after the page load is complete it goes back and loads in the designated elements. In this case, YouTube videos.

The way I have it is actually a two stage process. Instead of loading the videos inline as part of the page instead a small placeholder is specified for the video during the page load. When the page load completes it then goes back and replaces the placeholders with the video preview image with a "play" image on top that looks like the YouTube video. When you click on the "play" button it then, and only then, replaces the preview image with the actual video.

On a fast connection the "What are you listening to" thread pages should now load nearly instantly since no videos are being included and the preview images are pretty small. If you are on a slower connection, like some mobile devices, the page should still load pretty fast but you might be able to discern the empty placeholders until the page load is complete and the preview images are inserted.

Now the slightly bad news and what I'm currently trying to get past. On a desktop (or, in most cases these days, a laptop :P) with a decent connection and a modern browser the user experience is pretty seamless and other than the page loading a lot faster you don't notice anything. Mobile devices, on the other hand, like Android and iOS devices, are different. Modern mobile devices actually block videos from autoplaying in order to prevent data bandwidth abuse and to prevent mobile users from being bombarded with a bunch of autoplay videos from starting so that if you're in a crowded spot your phone doesn't start blasting the video audio.

The result then on mobile devices is that when you click on the 'play' button the video loads but doesn't actually start playing after the video loads. Instead the video loads and you have to hit the real play button from the video.

I'm going down the path of seeing if I can do some trickery to get the video to auto play on mobile devices after clicking the preview image 'play' button. If I can't get past it then my Plan B (or C, or maybe D) is to change the preview image 'play' button to made something other kind of "load video" indicator to avoid confusion as to why the video doesn't play after hitting the button.

So if you've been wondering where I've been the past few nights, it's been working on this. I have a bad habit of being obessed with solving a problem once I start digging into it. :coffee:
 

sci-fi-dude

1963, 1899 called they want every thing back....
Joined
Jul 20, 2017
Location
DFW
Its cool to have threads that you can put media on, it not cool if some one is a thread hog, oh well tis the way of the world....;)
 
Joined
Feb 14, 2017
Lol Kevin! Obsessed! :ROFLMAO: Heading over to a video thread now....dun dun dun!

One minute later...
KEVIN! It works! :omg:
Thank you! :clap:
 

Tom

An Old Friend
Joined
Dec 6, 2004
Location
Gulf Coast
Y'know Kevin, I recall a process in IE (internet options) that you can disable images and substitute them with image placeholders.
I used that feature way back when I was on netscape with an agonizing 14,200 kbps dial-up connection.
It really did help.
What you did with the video embeds is similar to that isn't it?

For me, now, if there is a large amount of elements loading on a page I just click the stop button and proceed to the latest post. In firefox its an add-on that comes with other useful buttons like top of page and so on.

It often feels like I'm a dinosaur because I am still using a PC.
Phones are wonderful tools but I have lots of issues that are age and health related that make them a no-go for me.
Plus, my posting style and how I look at webpages sways towards the older days of home PC users.
This is why I get a lot of flack over my posts.

Your dedication to making this wonderful community open to both types of users is one of the reasons I feel it is "Good Website".

Thanx!
:minion_shy:
 

Kevin

Code Monkey
Staff member
Joined
Mar 20, 2004
Location
Pennsylvania
There are still things bothering me but, yep, it's now live here. The 'What are you listening?' should now be loading faster for everybody. If anybody notices anything odd, please let me know what kind of device you are using and what browser & browser version you're using. At the moment quoting videos needs to be tweaked yet and I'm still thinking of the user experience of those using mobile devices.
Obsessed! :ROFLMAO:
It's both a blessing and a curse when I get my mind working on a problem. My 'day job' boss knows that I love figuring out mystery problems so his management of our team lets me do what I enjoy but my wife isn't happy when I'm working on personal sites. "Five more minutes, hon, then I'll head to bed. .... OK, five minutes, really. ... OK, hold on, I'm putting the laptop away. ... Five more minutes..."
Y'know Kevin, I recall a process in IE (internet options) that you can disable images and substitute them with image placeholders.
I used that feature way back when I was on netscape with an agonizing 14,200 kbps dial-up connection.
It really did help.
What you did with the video embeds is similar to that isn't it?
Yep, same general concept. In this case the image isn't loaded either until the page loads. Somebody on a really slow connection would see the page load with all of the posts and replies visible so they see the text then if they just sit there they'll then see the images being loaded after. Then if they click on the image the actual video loads.
 

Kevin

Code Monkey
Staff member
Joined
Mar 20, 2004
Location
Pennsylvania
I had to make a few changes as YouTube videos in the Media gallery were affected and quoted videos were not displaying the correct reduced size.

At the moment I'm not noticing anything else on my connections (home laptop, Android phone, work connections) so I'm going to put my mind at ease on this one for now.

The way I've got this implemented is pretty generic so I'll be working on getting it configured for XenForo 2.0 also so that it's ready when we migrate.
 

sci-fi-dude

1963, 1899 called they want every thing back....
Joined
Jul 20, 2017
Location
DFW
I had to make a few changes as YouTube videos in the Media gallery were affected and quoted videos were not displaying the correct reduced size.

At the moment I'm not noticing anything else on my connections (home laptop, Android phone, work connections) so I'm going to put my mind at ease on this one for now.

The way I've got this implemented is pretty generic so I'll be working on getting it configured for XenForo 2.0 also so that it's ready when we migrate.
Awesome Kevin! Say Kevin, we do seem to get a lot of robots visiting, lol, I'm not sure if I'm talking to a human or a robot? lol, oh well no problem.....:cool:
 

sci-fi-dude

1963, 1899 called they want every thing back....
Joined
Jul 20, 2017
Location
DFW
I had to make a few changes as YouTube videos in the Media gallery were affected and quoted videos were not displaying the correct reduced size.

At the moment I'm not noticing anything else on my connections (home laptop, Android phone, work connections) so I'm going to put my mind at ease on this one for now.

The way I've got this implemented is pretty generic so I'll be working on getting it configured for XenForo 2.0 also so that it's ready when we migrate.
I am now noticing that I cant download funny, or any gif's or images? Odd, it used to work just fine......
 
Top Bottom