Resource icon

XenForo Lazy Load YouTube Videos for Xenforo 2 1.0.4

No permission to download

Kevin

Code Monkey
Staff member
Joined
Mar 20, 2004
Location
Pennsylvania
Kevin submitted a new resource:

Lazy Load YouTube Videos for Xenforo 2 - Lazy Load YouTube in XenForo

This is a small add-on that defers loading embedded YouTube videos until the user clicks on the play button.

A preview image is shown as a placeholder with the familiar YouTube 'play' button on top. The video is not loaded until the play button is clicked.

For threads with a lot of embedded YouTube videos, such as the "What are you listening to?" thread here at Alien Soup, this allows the thread to...
Read more about this resource...
 

maszd

Ensign
Joined
Feb 16, 2018
Hi @Kevin
thanks to make this addon, make my thread faster with lot of youtube video :)
how to change width/height?
iam use this code on extra.less but not work with this addon enable

.bbMediaWrapper { width: 400px; }

thank you.
 

Kevin

Code Monkey
Staff member
Joined
Mar 20, 2004
Location
Pennsylvania
Hi @Kevin
thanks to make this addon, make my thread faster with lot of youtube video :)
how to change width/height?
iam use this code on extra.less but not work with this addon enable

.bbMediaWrapper { width: 400px; }

thank you.
I'll update it this weekend to respect the bbMediaWrapper class instead of using it's own class. For use here I like a 100% width I left it in there. It's Friday night now local time, I'll post an update either Saturday or Sunday night.
 

Kevin

Code Monkey
Staff member
Joined
Mar 20, 2004
Location
Pennsylvania
Hi @Kevin
Is this addon compatible with Xenforo 2.1?
thank you.
It should be but, after updating the site last night to 2.1.0 I couldn't help but notice little things like the ACP icon not appearing (because FA5 is now used instead of FA4).

I'll put out an update, likely next weekend, to update it to be friendly with 2.1.0 but in the interim it should be working fine. If you notice anything with it on your site let me now and I'll take care of it. 🙂
 

Kevin

Code Monkey
Staff member
Joined
Mar 20, 2004
Location
Pennsylvania
It should be but, after updating the site last night to 2.1.0 I couldn't help but notice little things like the ACP icon not appearing (because FA5 is now used instead of FA4).

I'll put out an update, likely next weekend, to update it to be friendly with 2.1.0 but in the interim it should be working fine. If you notice anything with it on your site let me now and I'll take care of it. 🙂
I take it back, it's giving me some issues tonight when I add a YT URL and then try to do a preview.

I'm in the midst of migrating a large site from XF 1.5.x to 2.1.x this week so it might be at least a few days or till the weekend before I have a chance to take a look. :(
 

Kevin

Code Monkey
Staff member
Joined
Mar 20, 2004
Location
Pennsylvania
What kinds of problems are you guys running into? It *seems* to be working on XF 2.1.x, just need the ACP icons cleaned up.
 

Kevin

Code Monkey
Staff member
Joined
Mar 20, 2004
Location
Pennsylvania
Kevin updated Lazy Load YouTube Videos for Xenforo 2 with a new update entry:

Tweaked for XF 2.1.x

This version requires XF 2.1.0 or above in order to be installed.
  • Fixed to use the minified version of the javascript file.
  • Changed iframe code to allow for autoplay complying with Google's updated policies on embedded media.
  • Tweaked the JS just a bit.
  • Updated the ACP icon, title, etc. to be consistent with other "CinVin" releases.
The current version of this add-on is always installed here at Alien Soup. Check our "What are you listening to?"...
Read the rest of this update entry...
 

Kevin

Code Monkey
Staff member
Joined
Mar 20, 2004
Location
Pennsylvania
Kevin updated Lazy Load YouTube Videos for Xenforo 2 with a new update entry:

CSS Tweaked for large resolutions

The CSS has been tweaked a bit for handling large resolutions better. Over at the Cameraderie photography forum we ran into the situation where the preview image of the video was not being properly centered in the middle of the frame on devices running really large resolutions. Smaller resolutions looked OK, only high resolutions were off.

While in there the CSS was tweaked a little to get rid of some unnecessary settings.

NOTE: All of the HTML...
Read the rest of this update entry...
 
Top Bottom